Update the client Slow version for Zoom Commercial (March 15, 2026)

Scheduled for Mar 15, 00:00 - 23:30 PDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Mar 09, 2026 - 14:46 PDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Mar 06, 2026 - 14:21 PST

Scheduled

Zoom will be updating the Slow version for Zoom clients on March 15, 2026:

Windows: 6.7.8

macOS: 6.7.7

Linux: 6.7.5

Android: 6.7.5

Android (Intune): 6.7.5

Windows (VDI): 6.4.17

For more information, such as specific versions, please refer to the Zoom Minimum, Prompted, and Slow/Fast Update Versions support article: https://support.zoom.com/hc/en/article?id=zm_kb&sysparm_article=KB0061900
Posted Mar 06, 2026 - 14:18 PST
This scheduled maintenance affects: Zoom Website (Download Center & Clients).